2

I am having trouble importing data to the created MIMIC-III tables. I followed the installing MIMIC locally instruction on mimic.physionet.org and failed at step 6. When I enter the code, it outputs an error message: ERROR: character with byte sequence 0x8f in encoding "WIN1252" has no equivalent in encoding "UTF8".

My OS is Windows 10 and I am using PostgreSQL 9.5. I created my tables in the default postgres database, the encoding is UTF8. Any help would be greatly appreciated. Thank you in advance!

enter image description here

  • have you made any progress with this? I am currently in a similar situation struggling to install MIMIC locally. I tried to send a private message but I am unsure if there is a way to do that on here. – J.McClelland Feb 9 '16 at 15:34
  • Going to give it a go tonight on my Windows 7 machine. I didn't have problems last time, so it might be something new in Windows 10 causing a conflict. – alistairewj Feb 10 '16 at 15:09
  • I ran it within PostgreSQL 9.5 on Windows 7 by launching psql shell and running: \i D:/work/mimic-code/buildmimic/postgres/postgres_load_data.sql @J.McClelland You could try running it interactively instead of with -f, but I have a feeling that won't fix it. It's probably a Windows 10 specific issue... unfortunately I don't have access to a Windows 10 machine. – alistairewj Feb 13 '16 at 0:13
  • Thank you for your replies, I have tried it again on both windows 8 and ubuntu, but the problem remains. I have also read several solutions which I found on the Internet but I still haven't manage to fix it yet. – Trung Feb 13 '16 at 7:17
  • Have you confirmed that the MD5 checksums of the decompressed CSVs match those in the checksum file? – tomp Feb 15 '16 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.