2

I believe this is the official source for DBLP (dblp computer science bibliography of the University of Trier, Germany).

I am having trouble unzipping the latest xml dump (2016-12-07). Since this file changes, here is a static file that I'm having trouble with as well: 2016-12-01 release.

In fact, the md5 doesn't even match up.

The md5sum specified in dblp-2016-12-01.xml.gz.md5 is 57e3406f01fa64a260affaef129d4afd

On my mac, when I type "md5 dblp-2016-12-01.xml.gz" I get a md5sum of 56903ba02acfcf46d0469565f14629b5

When I try to unzip it, I get an error

$ unzip dblp-2016-12-01.xml.gz
Archive:  dblp-2016-12-01.xml.gz
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of dblp-2016-12-01.xml.gz or
        dblp-2016-12-01.xml.gz.zip, and cannot find dblp-2016-12-01.xml.gz.ZIP, period.

or gunzip it

$ gunzip dblp-2016-12-01.xml.gz 
gunzip: dblp-2016-12-01.xml.gz: unexpected end of file
gunzip: dblp-2016-12-01.xml.gz: uncompress failed

Problem Solved

The issue seems to be my download mechanism.

I had my coworker download and unzip the file and it worked on his machine. So I had him send me his zip file and I was able to unzip it. The md5sum also checks out on his download of the zip file.

So it turns out it has something to do with the way I'm downloading it.

I downloaded using Chrome 54.0.2840.98 (64-bit) I also tried downloading using curl 7.49.1

But methods resulted in a file that I could not unzip.

Anyways, problem solved for now. I'll just have my coworker download all my files from now on ;)

  • Looking at the error message you provided, it reads as if you tried to unzip the *.md5 file. This is of course not possible, since the *.md5 file only holds the MD5 fingerprint. Please make sure that you target the actual *.gz archive file. – MRA Dec 8 '16 at 14:37
  • You're right, in my haste, I unzipped the wrong file, but it's still not working with the right file and two different tools – kane Dec 8 '16 at 18:27
2

I just tested the original files on the dblp live host system and I cannot reproduce this error.

md5sum yields the correct fingerprint for me:

> md5sum dblp-2016-12-01.xml.gz
57e3406f01fa64a260affaef129d4afd  dblp-2016-12-01.xml.gz

Also, gunzip -t dblp-2016-12-01.xml.gz does not complain, and gunzip decompresses the file without any problem. I could even validate the resulting XML file using xmllint:

> xmllint --noout --stream --valid --loaddtd dblp-2016-12-01.xml

Used environment:

  • Ubuntu 14.04.1 LTS
  • md5sum (GNU coreutils) 8.21
  • gunzip (gzip) 1.6
  • xmllint: using libxml version 20901

Hence, I am puzzled about what is going wrong here. Do you have double-checked that the file *.gz downloaded completely?

If there is a problem here I am very interested in learning the root cause, too.

  • Both files downloaded completely. I used a Chrome browser to do it. I also tried curl'ing the file down and got the same error when I try to unzip or gunzip it – kane Dec 8 '16 at 18:36
  • turns out the issue is with my download but I'm not sure why – kane Dec 8 '16 at 18:53
1

The latest release (8 dec) and your 1 dec example unpack fine with me*. The XML file contents seem valid (I have not verified that, a site like XMLValidate.com chokes on the size, as did my FirstObject XML Editor).

I used Microsofts File Checksum Integrity Verifier utility and the MD5 of the current release does NOT match either the .gz or the .xml file.

Are you sure you were not trying to uncompress it while the download was still in progress? Try another uncompress tool.

* I'm on Windows and use the built-in decompression with Total Commander

  • I tried unzip (v6.00) and gunzip (v264.20.1). I downloaded both files fully using my browser. Maybe the problem with the download method – kane Dec 8 '16 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.